Chrysler 300M Enthusiasts Club
  • Problems and Complaints

  • Repair Questions and Answers.
Membership Banner

Repair Questions and Answers.

Moderator: Moderators

Forum Statistics Last post
FOTKI
by FIREM  -   - in: Official Announcements
16 Replies 
 59863 Views
 by FIREM
 
Important: Forum Best Practices For All
by BOD  -   - in: Official Announcements
0 Replies 
 50899 Views
 by BOD
 
Terms of Service
by BOD  -   - in: Official Announcements
2 Replies 
 55209 Views
 by BOD
 
Forum Statistics Last post
Long Cranks Before Starting
by MY300M  - 
108 Replies 
 52097 Views
 by superblackbird00
 
*Gas tank straps--check yours if over 7 yrs old*
by EasyRider300M  - 
43 Replies 
 21856 Views
 by beespecial
 
Gas and brake pedal hard!
by CTexter  - 
2 Replies 
 25 Views
 by CTexter
 
Tensioner in rock auto kit wrong?
by First Lady  - 
4 Replies 
 141 Views
 by First Lady
 
'99 LHS Timing Belt do I or not?
by GoofySenior  - 
5 Replies 
 200 Views
 by In-trepid
 
Coolant won’t drain
by Nick82  - 
7 Replies 
 205 Views
 by LUNAT1C
 
Fuel Tank Strap Disaster
by Micah13  - 
2 Replies 
 122 Views
 by LUNAT1C
 
Struts never ending saga
by Countachqv  - 
5 Replies 
 138 Views
 by cin993
 
27 Replies 
 2490 Views
 by Phoenix
 
PCV hose replacement?
by LUNAT1C  - 
27 Replies 
 1782 Views
 by FIREM
 
2003 transmission problems
by Nick82  - 
7 Replies 
 252 Views
 by EasyRider300M
 
AC Issues - Help Me Diagnose
by M-Pressive  - 
10 Replies 
 1147 Views
 by LUNAT1C
 
1998 lxi concorde blower motor
by maddog56  - 
8 Replies 
 551 Views
 by maddog56
 
Key Stuck in Ignition
by StoneWhiteWolf  - 
10 Replies 
 2530 Views
 by FIREM
 
Sounds like an air leak
by JohnnyP  - 
4 Replies 
 206 Views
 by JohnnyP
 
Muffler Ground wire dangling, where to put it back?
by CTexter  - 
7 Replies 
 274 Views
 by Sneke_Eyez
 
Burning smell, misfiring, confusing codes
by CTexter  - 
12 Replies 
 923 Views
 by LUNAT1C
 
300M 2.7 Electronics error? PLS help
by Hagees  - 
1 Replies 
 737 Views
 by FIREM
 
Car won't move
by Travi510  - 
7 Replies 
 3514 Views
 by FIREM
 
6 Replies 
 277 Views
 by LUNAT1C
 
19 Replies 
 1962 Views
 by 1996LHS
 
Quick questions
by OttoOlin  - 
3 Replies 
 281 Views
 by OttoOlin
 
Rear Main Seal?
by M-Pressive  - 
4 Replies 
 1325 Views
 by FIREM
 
slow motion Transaxle leak
by Countachqv  - 
6 Replies 
 517 Views
 by FIREM
 
Transmission Output Speed Sensor Why's
by Ercouper  - 
6 Replies 
 309 Views
 by FIREM
 
Need help identifying engine harness wire
by LUNAT1C  - 
3 Replies 
 295 Views
 by FIREM
 
broken seat back
by Slick300M  - 
7 Replies 
 321 Views
 by TrepKing95
 
2 Replies 
 236 Views
 by TrepKing95
 
1999 300m - Missing Vacuum Hose
by noco  - 
2 Replies 
 215 Views
 by noco
 
No Bus Problems, No gauges
by Johncsavage3  - 
4 Replies 
 339 Views
 by LUNAT1C
 
'High Carbon Brake Rotors"
by cin993  - 
5 Replies 
 543 Views
 by cin993
 
6 Replies 
 527 Views
 by In-trepid
 
Transmission hard shift
by cin993  - 
1 Replies 
 277 Views
 by FIREM
 
Rocker Arm Tick
by In-trepid  - 
12 Replies 
 1488 Views
 by turboapc
 
PCM - 2003 Chrysler 300m Special
by e-peezy  - 
11 Replies 
 622 Views
 by e-peezy
 
Timing belts and cam gear alignment
by MoPar~Guy  - 
5 Replies 
 460 Views
 by Countachqv
 
no oil pressure warning light
by turboapc  - 
4 Replies 
 358 Views
 by FIREM
 
Brake master cylinder faulty?
by OttoOlin  - 
10 Replies 
 715 Views
 by turboapc
 
Shifter cable for a 2002 Chrysler 300M
by jrouter300M  - 
7 Replies 
 817 Views
 by LUNAT1C
 
Best method to prevent cam from snapping over?
by LUNAT1C  - 
11 Replies 
 1252 Views
 by cin993
 
'99 LHS Brake fitting leak
by GoofySenior  - 
6 Replies 
 630 Views
 by GoofySenior
 
Positive Battery Cable & Fusible Link Replacement
by mrnrod  - 
1 Replies 
 520 Views
 by FIREM
 
Cable 5114093AA
by Dschwartz  - 
6 Replies 
 839 Views
 by FIREM
 
16 Replies 
 3543 Views
 by redmax
 
Time for the crusher?
by user97  - 
12 Replies 
 802 Views
 by FIREM
 
Solving Oil Leak
by monte4  - 
15 Replies 
 721 Views
 by MoPar~Guy
 
Trunk harness typical issues, confirming fault?
by LUNAT1C  - 
6 Replies 
 844 Views
 by MoPar~Guy
 
One Touch Down Not Working
by Herb59  - 
3 Replies 
 536 Views
 by FIREM
 
A/M Electroluminescent module
by rustybronco  - 
7 Replies 
 840 Views
 by rustybronco
 
Stumbling When Starting
by M-Pressive  - 
11 Replies 
 601 Views
 by EasyRider300M
 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 105