Chrysler 300M Enthusiasts Club
  • Black Special 2020 M&M (maintenance and mods)

  • General Discussions about the 300M
2021 Calendar Banner

Membership Banner

General Discussions about the 300M

Moderator: Moderators

User avatar
 #385863  by M-Pressive
 September 19th, 2020, 8:13 pm
Radiator and hoses are in.

Bled it today and may need to do a bit more tomorrow. Still need to put the crossmember on the rest of the way and button it up.

So far so good with it. Really hoping this ends my cooling saga with this car.
Sneke_Eyez liked this
User avatar
 #385934  by M-Pressive
 September 24th, 2020, 7:29 pm
Add an alternator to the list of things that needed to be replaced.

A super annoying chirp was coming from it.

Put a new alternator in tonight. Not going to say it is fixed because well..... who the heck knows.
LUNAT1C liked this
 #385937  by StealthM
 September 25th, 2020, 12:40 am
Lol. Well that pesky evac code popped up again. But instead of being a LARGE LEAK its a small leak. Jeez. Looks like just a buff and wax before O/C. Gunna be a busy winter for StealthM..... Oh and that 300 dollar scanner will not talk to her....smh....
 #385940  by cin993
 September 25th, 2020, 9:18 am
For a year 2000 model you have a leak detection pump on the passenger side of gas tank, right?

So do I. Had a small leak that was tricky to pinpoint also. Smoke tested from the evap port in engine bay and plugged the rear vent valve. If your smoke machine gauge goes to zero (showing no leak) then it is the leak detection pump that's failed. It's very common. I took mine apart and the rubber diaphragm inside was slightly messed up.

put in a new OEM LDP and no codes since the fix
 #385946  by StealthM
 September 25th, 2020, 12:54 pm
That along with the charcoal canister and the solenoid under the hood was replaced with Mopar parts. And a new gas cap and filler neck. So it went from a large leak to a small leak. Will have to run the smoke test again and see what I can find.. thanks for your input.
User avatar
 #385973  by M-Pressive
 September 27th, 2020, 4:15 pm
Still making a noise.

Check my other thread.

Matches and lighter fluid standing by.
User avatar
 #386019  by M-Pressive
 October 4th, 2020, 7:44 pm
Went with the Continental belt that was suggested in the other thread.

Drove the car today, all good. Started it a bit ago, all good.

If it starts tomorrow and is quiet I will put the rest of the car back together and hope that it is good for a while.

Fingers crossed.
Sneke_Eyez liked this
User avatar
 #386170  by M-Pressive
 October 17th, 2020, 5:49 pm
Replaced the inner tie rod bushings today. Driver wheel had a little shake when it was in for inspection.

Moog crap parts lasted about two years. Went with a poly set from Rock Auto this time.
User avatar
 #386173  by M-Pressive
 October 17th, 2020, 7:01 pm
In-trepid wrote: October 17th, 2020, 6:57 pm What brand did you go with?
MEVOTECH MK7349

Bushings were way more stiff then the Moog ones ever were.
User avatar
 #386174  by In-trepid
 October 17th, 2020, 7:05 pm
I need to do them on the Intrepid and was debating on doing something other than Moog. I even considered one piece as I know they last longer. It's just a pain to get them pressed in and have to pull the whole assembly to do it.
User avatar
 #386175  by M-Pressive
 October 17th, 2020, 7:07 pm
In-trepid wrote: October 17th, 2020, 7:05 pm I need to do them on the Intrepid and was debating on doing something other than Moog. I even considered one piece as I know they last longer. It's just a pain to get them pressed in and have to pull the whole assembly to do it.
Yeah, I would love to do the one piece setup but I don't want to pull that much apart.

I bought three sets of this brand. M-Pressive and the black car now have them. They are going in John's car tomorrow.
EasyRider300M liked this
User avatar
 #386464  by First Lady
 November 14th, 2020, 7:07 pm
Did some winter prep today for the black car and it’s amazing how the paint really wakes up when you give it some love!!!

Keith did a great job with the buffer and it’s like glass now!!!

Image


It literally is like a mirror!!!

Image


Again, we feel like jello so you’ll find us plopped on the couch for the remainder of the evening!!
monte4 liked this
User avatar
 #386469  by M-Pressive
 November 14th, 2020, 7:18 pm
The best the car has looked since I bought it in 2015.
User avatar
 #386649  by M-Pressive
 November 27th, 2020, 6:49 pm
Working on finding out why my driver footwell was soaked the other day.

Looks like the driver door seal was not tight so I took it all apart and worked on crimping the part the goes on the metal back together so it is tight. We added some sealant in a spot that was clearly leaking.

Hoping to put it back together tomorrow.

Also, my mutli-function switch is starting to go bad. The flasher button pops up randomly. Ordered a new unit off eBay, hoping it comes tomorrow so I can swap it out.
User avatar
 #386651  by M-Pressive
 November 27th, 2020, 6:52 pm
Had a leaky fog light housing that I was able to fix today as well.

Pulled it apart and cleaned it well. Reassembled and realized it did not come with the rubber seal in the back. Swapped in a yard piece we had grabbed a few weeks ago.

All is well!
User avatar
 #386682  by Sneke_Eyez
 November 29th, 2020, 9:47 pm
Sounds like great progress!