Chrysler 300M Enthusiasts Club
  • Review of a WiTech VCI Pod clone from China with DRB III emulator

  • General Discussions about the 300M and other LHs
Ocean City 2019 Banner

Membership Banner

General Discussions about the 300M and other LHs

Moderator: Moderators

User avatar
 #362622  by remi
 
Hello all!

Two days ago I received something from China you might be interested in... A WiTech VCI Pod clone. I couldn't wait testing it and yesterday night I thought I should share some info about it with you guys.


1. Order and shipping
I purchased the VCI clone on a famous Chinese website (I'm not sure I can share the name here) on Oct. 24th for a bit less than $430 with free DHL shipping. Package was picked-up by the local post services on Oct. 27th. On Oct. 28th I got an email from DHL telling me to prepay the customs... The seller usually lowers the value on the custom declaration but France taxes start at 20€... Anyway, I had to pay about $30 of customs including "handling fees" from DHL... IIRC the VAT was around $5 only.
The DHL guy called me on Monday Oct. 31st but I wasn't at home so I told him to leave the package to a neighbor. I got the package on Nov. 1st when coming back home.


2. The VCI Pod itself
The VCI Pod comes in a small plastic suitcase, shipped as-is without any other protection whatsoever. But it's not a big deal because hopefully there's foam inside the case to protect everything inside. The case contains:
  • 1.20m USB cable, the cable is thick and quality looks good. The plastic bag says it's a USB 2.0 cable, ok fair enough.
  • OBD-II to DB-15 (VGA connector) cable, something like 1m-1.20m long. It looks very stiff! The cable is thick, both plugs are molded... I hope they will last as long as they look good.
  • Power cord, 220v@50hz/110v@60hz AC to 12v DC, I don't remember the amperage tho. It's a US plug so in EU a converter must be used.
  • The VCI Pod itself
  • A non-labelled CD-R (maybe it was a CD-RW!) with the WiTech v13.03.58 software and all the prerequisites (Adobe AIR v4, Acrobat Reader XI).
  • A sticker
As I used to live in San Francisco, I made myself a "power cord" with an old EU cord and a ACE Hardware power strip as you can see in this picture. Ok it looks awfully dangerous but it's not ;)
Image

Inside the box... The sticker is glued to the Pod now, and the CD is missing in this picture.
Image


3. Connecting to the computer

First install Adobe AIR and Acrobat Reader. During AIR installation, disable the automatic updates! Then start the WiTech install and follow the wizard... You will then see a "WiTech Manager" in the task bar near the time/date, start it and disable the automatic updates in the preferences menu.
You might also notice a yellow (or red) icon in the task bar, this is the WiTech server. It should turn green after a while (no need to connect the Pod).

You may connect the Pod to your computer using the provided USB cable, or a regular ethernet cable.
  • USB: On the first connection with the computer, the USB port will be recognized as a "virtual" network adapter. I'm using an old Windows XP laptop and no driver was required. The Pod acts as a DHCP server and your computer will be given an IP address, something like 172.22.22.x. The Pod address is 172.22.22.22. You don't need to know that... It's useless unless you're a nerd like me ;) Good thing about the USB, the Pod will boot on the USB power. Once it's connected to the car, no need for the power cord for basic use.
  • Ethernet: This is a bit trickier... There's no DHCP server here so you must configure your network card before you can connect to the Pod. Set your computer network adapter's IP to 192.168.0.whatever except 10, like 192.168.0.1. Netmask must be 255.255.255.0. Gateway and DNS are not mandatory, leave these settings alone. The Pod ethernet IP address is 192.168.0.10. I prefer ethernet to USB but in this mode the Pod must be powered by the power cord.
To summarize:
USB = no configuration on the PC, no power cord required on the Pod.
Ethernet = basic network configuration required on PC, power cord required. Ethernet plugs are supposed to be stiffer than USB tho...

And here it is! Pod near the shift lever, laptop on my laps, ready for some DRB III exploration!
Image


4. What's inside, and what differs from the original Pod
First let me tell you I have no experience with the original Pod. Here I'm making assumptions based on videos and pictures I got on the Web.

Let's look at the back of the Pod... There're the USB and Ethernet connectors, as well as a few LEDs. But these are missing:
  • Left of the DB-15 VEHICLE connector, there should be a RJ-11 connector labelled "TRIGGER".
  • Above the USB connector, there should be a WiFi antenna connector.
Image

No sticker there...
Image

Let's crack it open! Ok it's not that bad... The board itself looks fine, and it looks similar to an original one. Chips are mostly ATMEL, solder joints look good. However:
  • Bottom left corner, see the square SMD Ball Grid Array labeled U5? There should be the WiFi chip. On it's right, labelled J1, is the trace for the antenna connector.
  • Bellow the 1G SD card, there's J2 connector. J4 (located bellow the DB-15 connector) is missing as well. SMD board connectors are soldered on the original Pod, but they aren't connected. I guess they are used during manufacturing to flash some firmware, or for debugging.
  • Right above the SD card, there's something labelled J6 I think... I don't know for sure what goes there... There are also 3 vertical traces above these traces, near the metal plate. I think this should be Bluetooth chip and antenna.
  • Upper right corner, close to the DB-15 connector, this is where the RJ-11 connector should be.
  • Solder joints on the USB plug look weak, and I understand why these devices (including original ones) break so many plugs there! But thanks to the capacitors close to the plug, it's an easy fix.
Image

Now on the other side of the board, a few components are missing but who knows why. It's not uncommon to design a board with components that aren't implemented in production boards. One thing to note tho, the logo and the URL to Bright Star Engineering. I don't know if they used to build the WiTech boards...
Image


Next post will be about the DRB III emulator. Because the WiTech software supports vehicles from 2004 to 2013, our cars aren't supported and we must use the DRB3. But hey, that's why I bought this toy for :)
User avatar
 #362625  by remi
 
DRB 3 Emulator
1. Initialization
First thing first, the network configuration when the Pod is plugged to the computer through USB. Nothing to do here, this is only for information.
Image

Start the WiTech software (there should be a shortcut on your desktop after installation), and this is what greats you. If your car needs DRBIII, clic on the lower right button labelled "Launch DRB III". If you have a CAN car, clic "Next". As I only have a 2000 300M I'm gonna cover the DRB emulator only.
Image

And here it goes! The emulator fires up. Even tho there's a visual keyboard on the right side of the application, you may find easier to use your laptop keyboard for navigation. The most useful keys are:
  • Yes/No : Y or N on your keayboard
  • OK/Enter : ENTER
  • Navigation (left, right, up, down) : navigation keys on your keaboard
  • Break Page (used for Cancel or BACK in the emulator : CTRL+P on your keyboard
  • F1-F4 keys correspond to the icons shown on the bottom of the emulator's screen, when applicable
Click YES to continue, obviously...
Image


You're now on the main DRB screen. Select the DRB III Standalone and clic Enter.
Image

I'm missing a screenshot here, but select the first option (1998-2004 vehicles) and ENTER, then ALL if you have a LH car.
Image

And here are now the options for your car!
Image


2. SUB MENUS CONSTRUCTION
Most sub menus are alike and are built around the same options:
  • System tests : might contains sub menus depending on the selected module, you can perform self test routines here
  • Read DTCs : error codes for the selected module
  • Module Display : prints information about the module like part number or calibration ID
  • Sensor Display : all you need to know about sensors, like manifold pressure, TCM CVI, injector timing, voltages... The list would be endless ;)
  • Input/Output Display : shows status of actuators, switches and relay, basically everything that should be ON or OFF
  • Monitor Display : this menu will have a bunch of pre-set lists of sensor or IO values, each "list" correspond to common sensors to monitor for a given issue like no-start, etc...
  • Custom Display : you can define custom lists of sensors or IOs
  • Actuator Tests : check if your fans are running when told to do so, turn your injectors ON, test your headlights and related relays, etc...
  • Miscellaneous : well... I'd say that this menu contains configuration routines or values (TCM replaced, SKIM replaced, RKE horn chirp status, etc...)
Image


3. CODY CONTROL MODULE
Select the BODY INTERIOR line and ENTER. There is a missing screenshot here, as this BODY INTERIOR menu contains something like BCM, Memory Seats, Doors Gate and Confort, Cluster, Audio, HVAC, AC... Select the BCM sub-menu and press ENTER. The DRB will briefly tell you what kind of BCM you have, and you are then redirected to a sub menu dedicated to the BCM. Press ENTER or CTRL+P to skip the ID screen.
Image

Some BCM sensors and IOs:
Image
Image

List of available Monitor Views available:
Image

Actuator tests menu on the first screenshot. I chose to run the "ALL EXTERIOR LIGHTS" actuators test. A warning is displayed and after confirmation external lights started to blink. It's not obvious but in the third screenshot you can see the "STOP" icon on the lower right corner, you can "simulate a clic" on this button by pressing the F4 button or key on your keyboard. You're asked to confirm by pressing YES or NO. You can now exit the test by pressing CTRL+P (or Break Page button). If you exit the test while it's running without stopping the actuation, the test WILL CONTINUE!
Image
Image
Image
Image

And finally the miscellaneous menu for the BCM, and an example with the RKE Horn Chirp sub-option.
Image
Image

3.1 BODY - CLUSTER
Options for the cluster are limited. Basically you can check its part number, check if the cluster can communicate with the PCM... IIRC you can also validate the mileage (but not change it, hopefully). There's also an option in the Misc. section to initialize a new cluster... I've done it on mine but I don't know yet what it did ;) This screenshot shows the ID of the cluster installed in my car and I think there is a false information (or a misuse) as I have a US 150mph cluster...
Image

3.1 BODY - MEMORY SEATS
In the BODY menu, select the DOORS GATES AND CONFORT sub-menu. You can see a bunch of other options here but our cars aren't equipped with Door Modules or APM. I guess the Power Lift Module is the power sunroof?
Image

Select the MEMORY SEATS MODULE. Here is the ID of the module installed in my car, and a view of some sensors. In the MISCELLANEOUS menu I noticed the GLIDE CONTROL feature was OFF. I tried to enable this feature but I don't know yet how it turned out.
Image
Image


4. ABS
Long story short, I only have a screenshot with the single system test available for ABS. The MISC. section however will be usefull for brake jobs, as you can run the ABS bleeding routine from there :)
Image
User avatar
 #362626  by remi
 
I think the ENGINE and TRANSMISSION modules deserve their own post...

5. ENGINE
Available system tests:
Image

Module Display option, a second screen gives you more details...
Image
Image

Some sensors and IOs:
Image
Image

3 pages out of 5 of engine related actuator tests:
Image
Image
Image

The MISCELLANEOUS sections:
Image


6. TRANSMISSION
Select the TRANSMISSION section in the main menu. A sub-menu shows up but obviously the only section we, LH drivers, could be interested in is the first one, as we don't have the 3 last modules.
Image

After selecting the TRANSMISSION MODULE section, an ID screen tells you what kind of TCM you have. Press ENTER or CTRL+P to skip this menu. Side note: from what I can see there's an update available for this TCM based on the PDF available here (04606517AE was replaced by 04606517AF).
Image

System tests available for the TCM:
Image

Sensors and IOs values (note the Clutch Volume Index):
Image
Image

Actuators tests:
Image

And the miscellaneous section :)
Image



For now this clone is working great :) All these screenshots were taken with the Pod connected over USB without the power cord, ignition key in the ON position of course, engine OFF. For safety I'm gonna buy a new battery for the laptop as it doesn't hold the charge anymore, and I don't want the power to go down while connected to the car.
After these tests I switched to the ethernet connection and I ran an actuator test on injector #1. I was expecting the injector to click a few times (that's what FIAT and Alfa Romeo do) but the fuel pump fired up as well, filling the cylinder with fuel...

Next step : upgrading the TCM. It will require a subscription at TechAuthority.com for a day or three tho.

$430 for the Pod (380€), 28€ for customs, around 25€ for a new battery... Hardware cost will be 433€ ($480). A 1-day subscription at TechAuthority is $25, a 3-days subscription is $35. Around $500 in total. This is the biggest expense I have ever made for this car... Was it a wise one? I don't know yet and I don't wanna know ;)
 #362650  by piperdog
 
Neat post Remi. I have a DRB3 but have never fully leveraged its functionality. If you come across a DRB3 user's manual, let me know. I'd like to learn more about the functionality. Some things are obvious and others are not.
User avatar
 #362654  by remi
 
Do you mean these?
http://aie-services-2.net/Sprinter/Spri ... Manual.pdf
http://www.colorado4wheel.com/manuals/J ... _Menus.pdf

About the VCI clone... DO NOT CONNECT the computer to Internet with WiTech Server, WiTech software or DRBIII Emulator running! Now it's not working anymore... I'm gonna try to reinstall Windows on the computer and try again! I feel so stupid!
Anyway, with that being said I think it's gonna be hard to flash a module, even with a TechAuthority subscription!
 #362658  by piperdog
 
Thanks.

I have those two and they're helpful. However I thought there may be a more detailed user manual available to Chrysler technicians. Maybe there isn't.
User avatar
 #362659  by remi
 
I don't know... I'm new to all this ;)
Anyway, reinstalling Windows and WiTech solved the problem faced yesterday night.
User avatar
 #362727  by remi
 
This is a video taken today showing the transmission menu. There're a bunch of stuff there!
[bbvideo=560,315]
[/bbvideo]

Some guys at DI.Net are reverse-engineering the DRB Emulator so we could get as much information as possible using a simple ELM chip, hence the Wireshark process running along the emulator here (I'm sending them Wireshark dumps and logs).
User avatar
 #363178  by remi
 
Update :)

I tried the DRB Emulator on the Special I've seen last week and it worked fine. Meanwhile I managed to get a copy of the last version of the emulator, and a copy of the Enhanced emulator. That last one (along with the ST22, Supercard2, Crossfire and probably one I'm forgetting) doesn't replace the standard emulator but with some tricks it works. It looks faster than the standard one... But it might be me only.

However I had no luck flashing the TCM. I had to purchase a subscription from TechAuthority to download the flash as well as the last version of the J2534 Flash Application, installed everything on a brand new virtual machine to avoid compatibility issues... But the process doesn't even get to the first step: reading the part number from the TCM. The application asks to turn the ignition key to OFF, does some magic, and asks to turn ON again. And then it fails. It's strange because the TCM reboots to safe-mode (or it looks like so), the transmission indicator on the cluster lights up in full.
I tried to pull the fuse instead of turning the key but it's not better. According to what I can understand from the application logs, it's even worse!

I will try to dump the content from the SD card in the pod, and then update its firmware... We'll see!
 #366097  by cloves
 
Remi thanks for posting this review!

While I don't have a 300m I am thinking about getting one of these units for my 01 Durango. I have read that you can not program things like the pcm with the knock off units. I believe you have also confirmed this. Have you tried advanced things like programming a new key? I plan on using the unit to diagnose an alarm issue. My CTM is sounding the horn 3 times when I unlock the car, which means one of the sensors was set off. But I know for a fact that the alarm was not set off. I am suspecting a bad sensor but more then likely a bad CTM. Hopefully I can check to see if any sensors are reporting triggered with the DRB-III menu system. Anyways wondering if you have tried any advanced functions aside from flashing?

BTW someone asked for a manual for the DRB-III, I found this http://www.colorado4wheel.com/manuals/J ... _Menus.pdf pdf online.
User avatar
 #366098  by remi
 
Hello Rick, and welcome to the forum.

No I haven't tried messing with the key programming. Flashing was a failure for the TCM. However it looks like I could flash the EVIC if a flash was available. I used a flash for another model, made some changes to the flash file descriptor (basically it's an XML file describing the flash, what part number it replaces, what old part numbers are flashable, etc...) but I didn't press the button as it would have break the EVIC.

This is what I've tested:
Alarm: tried to force activation but I'm missing a sensor in the trunk, so it won't activate.
EVIC/ATC: screens autodiagnostics
Memory seats: enabled the glide feature (easy exit) on a 1999 and 2000 Ms!
ECU tests: Fuel injector #1 (it fires the fuel pump and opens the injector, I guess you need to have the injector off the car to really see what's going on).
BCM tests: Lights tests (it flashes all lights or a specific one you choose so you can see if the bulb/wiring/bcm are ok).
TCM tests: I don't remember but I think the engine has to be running for the tests to complete (you are supposed to look at the RPMs while the TCM triggers the solenoids).
RKE: tested the keys (it tells you which button is pressed on the fob)

And there are so much values you can read... Basically you can read all sensors of course, but you can get the interior light dimmer switch output, sun sensor value, heated seats temperature IIRC... It's a great tool but IMO it doesn't worth that much considering you cannot flash modules.
 #366177  by cloves
 
Thanks for the update Remi,

Now are you missing the sensor because you took it out? I would be worried flashing the ECM, you hose that God knows what the recovery process it. I saw you can get a temp membership and I believe download any relevant files for your car at the tech site right?

I am so tempted just because 1 I have to get another key programmed and I might have to program a new CTM because my alarm horn beeps 3 times when I unarm the car. This indicates that one of the sensors triggered which of course it hasn't because the alarm has not gone off while I am on site.

How did you figure out that you could flash the EVIC?

Trying to think of other things that would make this a smart purchase. The clones are running around 400.

PS you have the car turned on when doing the sensor tests or no?
User avatar
 #366184  by remi
 
Factory alarm was an option for most LH cars, including mine... I'm missing the sensor because I'm missing the alarm ;)
Flashing the PCM/ECU is freaking me out... I did try on the TCM because I have a 2000 car, TCM and ECU are dedicated boxes unlike the 2001/2002 and up. Worst case scenario: I break it, and I replace it.

Flash files are available from TechAuthority website but you need a subscription. A 1 or 3 days subscription is enough. The flash application packaged with WiTech software 13.x is old, so you should use the one from TechAuthority. The thing is, it also downloads a newer driver and WiTech server program, and they won't work with WiTech 13.x or 14.x. For this reason I used my corporate laptop and/or a virtual machine, dedicated to the flashing app.
Once you have selected a flash on TechAuthority website, it downloads a few files in your computer temporary folder. You can save these files (basically I copy-pasted the files in a new folder named after the flash part number) and reuse them latter. That way, you don't need the TechAuthority subscription anymore. It should also work for real DRBIII devices. Simply copy-paste the files from where you saved them to your temp folder. IIRC you have to start the flash application once to get the required subfolders created in the temp folder.

With the 13.x software version, from the DRBIII emulator, you can run the non-powertrain flash application. And this flash app was able to read the part number from the EVIC on the car, while the powertrain flash app (and also the flash app from TechAuthority) could not read the part number from the TCM. That's why I'm guessing I should be able to flash the EVIC. Also I talked with a guy on YouTube who was able to flash the EVIC on his Jeep (2002 IIRC).

For most tests, I had the engine not running, key in RUN position.

Want a good reason? lol!
That's exactly why I waited so long... Well you can talk to the ABS module and read the codes, which is not possible on the 300M with a cheap ELM327! You can run the ABS bleeding procedure (not tested yet), read the Clutch Volume Indexes from the transmission, pair a new PCM/BCM/SKIMM module (not tested)...
I wouldn't get the newer dongles, they run a bit cheaper on AliExpress but I've read they don't work with the TechAuthority web components, which is the all point of having the new device over the VCI Pod. So don't buy one!
 #366213  by cloves
 
Remi, apparently from what I read the new minipods which are cheaper will not run the DRB-III on anything before 2004.

I wonder if there is a way to see what downloads are available without having a membership its based on specific vehicle right?

So do you download the individual flash files or is part of a package that includes the driver update. Really interesting, so basically you can't avoid the hardware driver update when you want to install say the tcm update?

I believe hardware updates for the cars is rare right? I know there is one recall that was done on my truck and they did the hardware update for the transfer case I believe.

I would be curious to also see the sensor outputs while the car is running. I have a tech2 and live sensor and recording is great for diagnosing issues with the car.
 #369321  by menotu
 
hello, does V16.04.12 witech clone works with a 2004 300m?
I want learn a new fob and a new ignition key (and read some sensors)....

price is nice. 1 hour in a chrysler garage costs the same....

https://www.aliexpress.com/item/2017-Ne ... 92629.html
User avatar
 #369324  by remi
 
To be honest I don't know. According to http://kb.dcctools.com/index.php?View=entry&EntryID=554 the MicroPOD II can run the enhanced DRB III emulator with WiTech App v16.04.12. However this app version might require to run online, connected to TechAuthority. If it does you're screwed because it will be banned based on its ID.
If you try, post your results ;)
 #369866  by daddio96
 
Does anyone have a copy of the Witech Install file for version 13 or know where to get a copy? My laptop crashed and I am unable to find my install disc. I would appreciate any help you could provide.
User avatar
 #369875  by remi
 
I won't post any link here. However you might want to get 14.02.56 instead, it should work. It worked for me anyway, but the Pod has to be upgraded (there's a wizard that will pop up on first start). Beware of the required Adobe Air 3.0 version.
 #373436  by vibit
 
Hello can you pass me the SD Dump you make i was triying to update (by mystake) win Ver.17.xx.xx of witech and my VCI Pod crashed and cant restore i can connect the SD to the PC al try to put your SD Dump file and test if i can get it back, you can send me link via PM if you want.